2018年1月11日 星期四

Unity 2018.1開始停止支援MonoDevelop-Unity

作者:Lukasz Paczkowski 原文
潤稿:Kelvin Lo


從Unity 2018.1開始,Unity將不在綁定與MonoDevelop-Unity一起發行,並且在Unity 2018.1後的版本也不再支援使用MonoDevelop-Unity開發。

隨著Unity中.NET 4.6腳本執行庫(測試版)的升級,Unity開始支援C# 6.0及後面版本提供的全新C#功能。為這些新的C#功能提供一個適合的IDE體驗,對於我們來說也十分重要。

目前的MonoDevelop-Unity 5.9.6並不支援最新的C#功能,也無法在Unity裡除錯這些.NET 4.6的程式。因此我們將做出二項改變。

  1. 從Unity 2018.1開始將不再支援MonoDevelop-Unity 5.9.6。MacOS和Windows的安裝程式也會將它移除。
  2. 從Unity 2018.1開始,Visual Studio for Mac將作為MacOS上的唯一C# IDE。在Windows上會繼續保留Visual Studio 2017 Community,並不再將MonoDevelop-Unity作為選項。

自Unity 5.6.1開始,Visual Studio for Mac已整合 Unity的連接套件,即支援最新的C#功能也支援在.NET 4.6程式執行時上除錯C#程式。MacOS上的MonoDevelop-Unity開發者可以下載並安裝Visual Studio for Mac並開始使用。


C# IDE選項


除了Visual Studio for Mac和Visual Studio 2017 Community之外,現在還有一些其它的C# IDE可用。

Visual Studio Code (Windows, macOS, Linux)

在Preferences裡將Visual Studio Code設定為外部編輯器時,Unity就可以在Visual Studio Code裡打開程式。要支援C#代碼編輯與Unity C#除錯,還需要安裝下列內容。



JetBrains Rider (Windows, macOS, Linux)

當在Preferences裡將JetBrains Rider設定為外部編輯器時,Unity就可以在JetBrains Rider裡打開程式腳本。

JetBrains Rider是一款基於IntelliJ和ReSharper的.NET IDE,並包含ReSharper大部分功能。Rider還支援所有最新的C# 6.0功能,以及在Unity中進行.NET 4.6腳本運行庫上的C#除錯。查看更多相關內容

沒有留言:

張貼留言

關於我自己

我的相片
Unity台灣官方部落格 請上Facebook搜尋Unity Taiwan取得Unity中文的最新資訊