2017年7月23日 星期日

Unity即將停止支援DirectX 9

作者:Martin Gram 原文
潤稿:Kelvin Lo


從Unity 2017.3開始,將不再支持Windows平台的DirectX 9 API。意思就是到時候Unity編輯器預設不支援Windows XP了。

執行版本

Unity 2017.3

不再支援的原因

由於微軟官方也不再為Windows XP提供支援,加上使用Windows XP的系統硬體也越來越少,許多Unity的新功能也和這個API不相容,同時維護好幾個不同的DirectX API版本(9、11及12)的難度也越來越高。所以我們決定停止支援DirectX 9 API。


參考數據:

全球的DX9圖形API的使用率大約占比5.1%,但根據遊戲
平台Steam上的統計顯示,截止2017年6月DX9 GPU使用只占了0.37%。


接下來的計畫

我們將從Unity 2017.3開始,取消對DirectX 9的支援,屆時Unity編輯器與發佈的PC平台都將不支援DirectX 9 API。

另外,我們發現許多已知的DirectX 11當機問題,都是由於Driver驅動程式未更新到新版導致。我們正在思考避免這種問題造成當機的解決方法,並能反饋問題給我們來第一時間修復。
如果你有以下問題可以聯繫我們反饋意見:
  • 你的工作流程或現有設定必須繼續使用DirectX 9
  • 你遇到一些Bug或功能行為必須使用“-force-d3d9”命令列參數,將圖形API降級為DirectX 9才能解決
可以從這個論壇反應(英文)

對Windows XP的支援

雖然未來Unity編輯器預設不再支援DirectX 9 API,但不代表WindowsXP就不能執行可執行檔專案。你可以在Unity裡面把Windows採用的圖形API手動改為採用OpenGL。步驟如下:
  1. 從Edit > Project Settings > Player,找到Player Rendering Settings設定
  2. 取消勾選Auto Graphics API for Windows ,並選擇OpenGL作為Windows平台的圖形API


請注意:電腦必須有DirectX 10或Open GL 3等級以上的GPU,最好驅動程式也不要太舊(2010年以後的理論上就能執行),以確保Windows XP能夠支援OpenGL。

參考數據:

沒有留言:

張貼留言

關於我自己

我的相片
Unity台灣官方部落格 請上Facebook搜尋Unity Taiwan取得Unity中文的最新資訊